Arquivar julho 2013

SCRIPT PARA DDNS CHANGEIP

Vídeo Ensinando Como Fazer a Configuração

==============SCRIPT ESTA ABAIXO =======================
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# EDIT YOUR DETAILS / CONFIGURATION HERE
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser “YourChangeIPUserID”
:global ddnspass “PASSWORD”
:global ddnshost “MyRouterHostname.example.org”
:global ddnsinterface “ether1”
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# END OF USER DEFINED CONFIGURATION
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnssystem (“mt-” . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip
:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info “DDNS: No interface named $ddnsinterface, please check configuration.” }
:if ([ :typeof $ddnslastip ] = “nothing” ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = “nothing” ) do={
:log info (“DDNS: No ip address present on ” . $ddnsinterface . “, please check.”)
} else={
  :if ($ddnsip != $ddnslastip) do={
    :log info “DDNS: Sending UPDATE!”
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip “/”] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
  } else={
    :log info “DDNS: No changes necessary.”
  }
}
# END OF SCRIPT

Configurando um ddns para o mikrotik no site no ip

==============SCRPT==============================

# No-IP automatic Dynamic DNS update

#————— Change Values in this section to match your setup ——————

# No-IP User account info
:local noipuser “E-MAILDONOIP”
:local noippass “SUA_SENHA”

# Set the hostname or label of network to be updated.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas.
:local noiphost “URLDINAMICA”

# Change to the name of interface that gets the dynamic IP address
:local inetinterface “INTERFACE”

#————————————————————————————
# No more changes need

:global previousIP

:if ([/interface get $inetinterface value-name=running]) do={
# Get the current IP on the interface
   :local currentIP [/ip address get [find interface=”$inetinterface” disabled=no] address]

# Strip the net mask off the IP address
   :for i from=( [:len $currentIP] – 1) to=0 do={
       :if ( [:pick $currentIP $i] = “/”) do={
           :set currentIP [:pick $currentIP 0 $i]
       }
   }

   :if ($currentIP != $previousIP) do={
       :log info “No-IP: Current IP $currentIP is not equal to previous IP, update needed”
       :set previousIP $currentIP

# The update URL. Note the “3F” is hex for question mark (?). Required since ? is a special character in commands.
       :local url “http://dynupdate.no-ip.com/nic/update3Fmyip=$currentIP”
       :local noiphostarray
       :set noiphostarray [:toarray $noiphost]
       :foreach host in=$noiphostarray do={
           :log info “No-IP: Sending update for $host”
           /tool fetch url=($url . “&hostname=$host”) user=$noipuser password=$noippass mode=http dst-path=(“no-ip_ddns_update-” . $host . “.txt”)
           :log info “No-IP: Host $host updated on No-IP with IP $currentIP”
       }
   }  else={
       :log info “No-IP: Previous IP $previousIP is equal to current IP, no update needed”
   }
} else={
   :log info “No-IP: $inetinterface is not currently running, so therefore will not update.”
}

=========================FIM=============================

Curso MK-Auth

ADQUIRA JÁ O MK-AUTH NAS NUVENS ONDE VOCÊ PODE TER ACESSO DE QUALQUER LUGAR DO MUNDO, COM O VALOR DE APENAS 60,00 R$ MENSAIS VOCÊ VAI TER UM FANTÁSTICO SISTEMA DE GESTÃO PARA PROVEDOR DE INTERNET.
R$ 60,00 Mensais